Tag Archives: Cocos2D-X

mac下编译运行Cocos2d-x 2.0.4 android

由于从2.0.3开始,cocos2d-x把libcocos2dx从每个android项目中单独挪了出来,放在了{你的cocos2d-x源代码位置}/cocos2dx/platform/android/java,所以在eclipse中导入android项目后,都需要import这个位置的lib项目进来,不然都会提示找不到libcocos2dx

导入libcocos2dx如果报错,如下图

libcocos2dx需要JRE 1.6版本,mac默认就有,我是lion系统,终端输入java -version,提示1.6版本

右击libcocos2dx,选择属性,从java compiler选项卡里选择compilance level为1.6,然后就无错可以继续编译运行了

Tagged ,